Incoming Calls to Mobile numbers

Incident Report for CircleLoop

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 12:49 UTC

Identified

We have identified an issue with receiving calls to mobile number on CircleLoop.
This has been raised with our Mobile number provider.

Updates to follow.
Posted Aug 05, 2025 - 10:39 UTC
This incident affected: Inbound calls.