Android application temporarily unavailable to new downloads.
Incident Report for CircleLoop
Resolved
This incident has now been resolved and the App is available for new downloads on the PlayStore.
Posted Aug 03, 2021 - 10:06 UTC
Monitoring
Android application temporarily unavailable to new downloads, existing customers with the app already downloaded should be unaffected.
Posted Jul 30, 2021 - 09:37 UTC