Desktop App Update Issues

Incident Report for CircleLoop

Identified

We have changed the auto updater so that it downloads the previous version, so no error messaging should appear now.
Posted May 26, 2026 - 13:17 UTC

Investigating

Some users on older versions of the desktop app are unable to update to our newest version.
Users will need to delete and reinstall the app - we are currently investigating the cause.
Posted May 26, 2026 - 12:55 UTC