Outbound calls failing to connect
Incident Report for CircleLoop
Resolved
Outbound calling now restored.
Posted 9 months ago. Oct 10, 2018 - 10:44 UTC
Investigating
Outbound calls are currently failing to connect. The team are urgently investigating the issue.
Posted 9 months ago. Oct 10, 2018 - 10:03 UTC
This incident affected: Outbound calls.