Degraded call quality
Incident Report for CircleLoop
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 07, 2018 - 17:16 UTC
Investigating
We're currently investigating an issue with some reported incidents of degraded call quality. We're working hard to get this resolved for you as quickly as possible.
Posted 7 months ago. Dec 07, 2018 - 14:31 UTC
This incident affected: Inbound calls and Outbound calls.